STOP: 0x000000C4 after installing KB4056894 – I guess M$ has used too many ¢heap resources recently…

My old Dell desktop (Dimension C521, AMD Athlon 64 X2 Dual Core 3600+) got hit twice since Saturday and did not recover from the blue screen yet (it was finally fixed 30min ago). It runs Windows 7 and of course, it is “AMD inside”. Some online forum said this is caused by the friendly fire from Microsoft who tried to fix the Spectre and Meltdown which affect Intel chips.


I have left my desktop on automatic-update since its upgrade to Windows 7 and I left it in sleep mode or running state most of the time. Last Saturday morning, I found it stuck at a blue screen, which seemed new to me, because it didn’t show a lot of information like a normal blue screen does.


010550690

I was lucky on Saturday. After cycled the power, the try-normal boot didn’t work, so I tried to let it fix by itself and it works. It looked like nothing happened after that and ran without a problem for 3 days.


Last night, I left it run overnight, then in the morning, I saw the blue screen again. I tried to fix it used the same option as last time, several times. It didn’t work. So I did some research and found the following, I may try them after work today.


BTW, I don’t have third-party anti-virus installed on my PC, only have MS Security Essentials and that is up-to-date.



After 3 days, MS gave sort of acknowledgement, but no fix yet.


https://support.microsoft.com/en-us/help/4073707/windows-operating-system-security-update-block-for-some-amd-based-devi



Okay, after some research and thoughts, I started to recover my PC when I got home.

First thing I tried is to let it boot and recover by itself, as expected it failed, the same as this morning. Then, I choose an advanced mode in the same session, and managed to get to a DOS prompt, but when I use the DISM command to remove the package, it gave me error said something about running mode. So I stopped there, went to the basement to find the Windows 7 installation disk.

Next, I use the Windows 7 installation DVD to boot the PC, went into recovery mode, similar interface as last try, I got the DOS prompt, and I ran the same DISM command, this time it had some progress as showing here:

image

It took a while and at the end, it’s a success.

image

After reboot, it still tried to finish the last “failed” update and stuck in this screen for quite some time.

image

Then it let me login, everything seems back to normal, except in the update history I saw this.

KB4056894

The latest pending update was the culprit, it still showed Pending state, but after a few minutes and a pop-up message, the status changed to Failed.

So that’s the adventure lately, and here is the command I ran, copied from one of those online communities.

dism /image:d:\ /remove-package /packagename:Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.24002.1.4 /norestart /scratchdir:d:\temp

Some thoughts though, after this. What about many other normal users, homeusers, system admins?  Let’s wait and see how Microsoft can fix this for thousands if not millions of AMD-based PCs/servers when they are in bricked mode.

Advertisements